Before you ask please READ THIS

Superior 2 - Back to ThemeForest

AirAir
edited August 2017 in Superior Posts: 10,000
Hi there guys.


Superior is returning to ThemeForest! It is available under this link http://themeforest.net/item/superior-responsive-multipurpose-wordpress-theme/6212921

To be honest - Visual composer issues was main reason why we took down Superior theme from ThemeForest market.
We first released Superior just before they updated their plugin to version 4.0 which was highly incompatible with that what was in 3.7.x versions.
We delayed update to 4.0 for few weeks - this how much work and testing it required for us.

Upgrading to 4.0 meant that sites of our clients will look different and probably have broken layout.
We had to merge plugins 3.7 with 4.0 to get consistent look, and to face our clients demand to get newest version of Visual composer with theme.
From that point each update of VC was nightmare, but we kept this under control.
But version 4.3.x was next shift in incompatibilities and changed grid system in builder.

Keeping up to date is not always best way to do things :-)
But we can't explain all above to every customer...
And that is when we removed Superior from ThemeForest.

Anyway, now it all looks better with VC, and that is why we do this "not fully compatible Superior 2" version of theme.
In this new version of VC they have introduced very useful elements, and everyone could (and should!) benefit from them.

Firstly we wanted to remove all our custom elements for builder, but after checking all out, we have removed only problematic ones.
Other we have renamed to "Theme name_of_element" so you should have most of styling intact.
However we advise to not use them if you will face any problems, as they might come in conflict with builder styles.
We also re enabled all Builder elements that we have blocked previously as we didn't like their behaviour.
We believe that user will not use elements that for him/her are looking/working bad:-)
There are also some elements that we have added to builder since first version, and they should work good.


Here is list what we did in topic of builder(Visual composer) elements:
-Removed theme specific styling for Tabs, Tour, Accordion and Faq elements.

-Removed "Button" element in favour to builders "Button" and "Button 2" elements(you will need to replace all removed shortcodes)

-Renamed "Button" to "Theme Button"
-Returned back builders "Button" element

-Renamed "Call to Action Button" to "Theme Call to Action Button"
-Returned back builders "Call to Action Button" element

-Renamed "Progress bar" to "Theme Progress bar"
-Returned back builders "Progress bar" element

-Renamed "Separator" to "Theme Separator"
-Returned back builders "Separator" element

-Removed theme specific settings for Single image

-Removed theme specific settings for vc_posts_grid
-Removed theme specific settings for vc_carousel
-Removed theme specific settings for teasers
-Removed "Recent Posts", "Recent Works", "Recent Galleries". You will have to use "Post grid" or "Post Masonry grid" instead
-Added "work" and "gallery" to post type list in "Post grid" and "Post Masonry grid"
-Added tiny style for "Single image", so it should react better in columns.



So what you should do now?
-Get new Superior version from ThemeForest
-update VC while updating theme http://apollo13.eu/docs/superior/#!/installation_update_update_theme
-You are done, but remember to activate new builder options http://apollo13.eu/docs/superior/#!/activate_builder_options

Now it would be good if you scan your pages to see if everything is working fine, and correct if there are any problems.

We hope everything will go well!



----------------
If you still want to use Superior 1.9.X use below link:
http://goo.gl/WylhWF

This package contains everything:
- Superior 1.9.X,
- PSD Files,
- Demo Data
- Child Theme


With kind regards.
Post edited by Air on

Comments

  • Posts: 66
    Thanks for your hard work and for adding it back on Themeforest. It's a great theme so I'm sure there will be many more sales.

    In trying to recreate the previous version (before the update), I did run into some styling issues that I wanted to share with you.

    For some reason, there is about 20px of margin above the text in a new row.

    I created a black full width row and added a content module, the outcome is that there is always more space at the top of the content than on the bottom. Don't know if that extra margin could be removed (see alexnavas.com under the header banner - it's the black bar that reads "If you have a big vision...")

    I also tried styling the recent posts module using Post Grid but I can't get it looking right. The featured images come out multiple times layered on each other and there is no longer the scroll option for more posts like before. Additionally, the featured image were all the same dimensions before and now they're different dependent on the size of the actual image.

    I've attached images of both versions for your review. The lighter image is before the update with your build in recent post styling, the darker image is after the update using post grid.

    It would be great to have your version of the recent posts and project back since the styling and formatting was perfect.

    It also appears that the width of the wide version of the theme was reduced from 1080px wide to 1050px wide. Not sure if it's just on my end or yours too.

    It seems most of the issues are spacing, but nothing is severely broken from the update which is good.

    I'll keep going through stuff to see what else is happening.

    I appreciate your help with this. Support has been great as usual!
    Screen Shot 2015-03-25 at 1.05.47 AM.png
    1142 x 506 - 314K
    Screen Shot 2015-03-25 at 1.05.57 AM.png
    1112 x 486 - 331K
  • AirAir
    Posts: 10,000
    Hello:-)
    AlexNavas said: For some reason, there is about 20px of margin above the text in a new row.

    I created a black full width row and added a content module, the outcome is that there is always more space at the top of the content than on the bottom. Don't know if that extra margin could be removed (see alexnavas.com under the header banner - it's the black bar that reads "If you have a big vision...")
    It is margin of paragraph that is there.
    I believe that this custom CSS should fix it
    .wpb_wrapper p:first-child {
    margin-top: 0;
    }
    If it wont break anything other for you then I will add it to theme styles.
    AlexNavas said: I also tried styling the recent posts module using Post Grid but I can't get it looking right. The featured images come out multiple times layered on each other and there is no longer the scroll option for more posts like before. Additionally, the featured image were all the same dimensions before and now they're different dependent on the size of the actual image.
    Be sure you are using "Post grid" not "Posts grid" element. Second one is deprecated by VC. Scroll is also not available in new VC. They removed it totally.
    Also for test time remove all your custom CSS, to be sure it is not interfering. However looking on your screen shot I am almost sure you use different element.
    On screen shot you can see how does it look/work for me.
    image

    AlexNavas said: It also appears that the width of the wide version of the theme was reduced from 1080px wide to 1050px wide. Not sure if it's just on my end or yours too.
    Visual composer elements are affected by this style that add 15px padding on both sides

    .vc_col-xs-1, .vc_col-sm-1, .vc_col-md-1, .vc_col-lg-1, .vc_col-xs-2, .vc_col-sm-2, .vc_col-md-2, .vc_col-lg-2, .vc_col-xs-3, .vc_col-sm-3, .vc_col-md-3, .vc_col-lg-3, .vc_col-xs-4, .vc_col-sm-4, .vc_col-md-4, .vc_col-lg-4, .vc_col-xs-5, .vc_col-sm-5, .vc_col-md-5, .vc_col-lg-5, .vc_col-xs-6, .vc_col-sm-6, .vc_col-md-6, .vc_col-lg-6, .vc_col-xs-7, .vc_col-sm-7, .vc_col-md-7, .vc_col-lg-7, .vc_col-xs-8, .vc_col-sm-8, .vc_col-md-8, .vc_col-lg-8, .vc_col-xs-9, .vc_col-sm-9, .vc_col-md-9, .vc_col-lg-9, .vc_col-xs-10, .vc_col-sm-10, .vc_col-md-10, .vc_col-lg-10, .vc_col-xs-11, .vc_col-sm-11, .vc_col-md-11, .vc_col-lg-11, .vc_col-xs-12, .vc_col-sm-12, .vc_col-md-12, .vc_col-lg-12 {
    position: relative;
    min-height: 1px;
    padding-left: 15px;
    padding-right: 15px;
    box-sizing: border-box;
    }
    I don't like it either, but this is one of trade off of using default VC, and as I said, we have removed lots of our improvements for VC, so we can continue to have Superior available and don't get headache on VC update:-)
    You can try to change this style(copy to custom CSS and change), but there is no guarantee it will not affect some other parts of VC layout.
    By the way I am still amazed that all users of VC accepts this 30px narrower content.

    With kind regards.
    su.png
    881 x 1144 - 456K
  • Posts: 66
    I was able to take out the paragraph top margin manually through the VC design options in the content module. I had to add -20 to the top margin area and it lined up fine.

    For Post Grid, I'm using the correct one (not post grids). I was just trying to get the featured image to be the same size as your original styling since the featured image is taller and narrower than your version and they aren't shrinking down to show the entire image, only the center part of a bigger image.

    Is there a way to customize the size of the featured image in the Post Grid so they look like your previous version (which are the same as the similar posts sizing on single posts).

    Lastly, I changed the css for the size padding but it was causing errors on the VC backend editing option. Whenever I saved the page for the changes, it caused the page editing to go back to Classic mode instead of the VC builder, and it changed the page setting details back to default.

  • Posts: 66
    One more thing. I tried using Post Grid and Post Masonry Grid for works and pointed to "Work" as the source but nothing showed up. It's not pulling in the My Works content.
  • AirAir
    Posts: 10,000
    AlexNavas said: Lastly, I changed the css for the size padding but it was causing errors on the VC backend editing option. Whenever I saved the page for the changes, it caused the page editing to go back to Classic mode instead of the VC builder, and it changed the page setting details back to default.
    When you added custom CSS? This is really unrelated and I see no way how one could affect other. What exactly have you changed?
    AlexNavas said: One more thing. I tried using Post Grid and Post Masonry Grid for works and pointed to "Work" as the source but nothing showed up. It's not pulling in the My Works content.
    Have you got your version of theme from ThemeForest or one that I posted few weeks ago? ThemeForest version have this fixed.
    AlexNavas said: Is there a way to customize the size of the featured image in the Post Grid so they look like your previous version (which are the same as the similar posts sizing on single posts).
    I couldn't find anything now. I will take another look later today or tomorrow.

    With kind regards.
  • Posts: 66
    1.Your first point is correct. I removed the css for the width and every other page was fine, but when I saved the homepage, it went back to default settings and the classic view instead of the builder view. Haven't figured out what is causing this.

    2. I am using the most recent version from Themeforest which I believe is 2.0.1 updated yesterday. Still isn't bringing in works.
  • Posts: 8
    Do existing customers need to buy this NEW theme or do we get it for free? Just checking.
  • AirAir
    Posts: 10,000
    AlexNavas said: 2. I am using the most recent version from Themeforest which I believe is 2.0.1 updated yesterday. Still isn't bringing in works.
    I believe you have same problem as here http://support.apollo13.eu/discussion/3043/error-with-new-1.62-update#Item_1 - I will resolve this today.
    imglobal said: Do existing customers need to buy this NEW theme or do we get it for free? Just checking.
    If you bought Superior theme on themeForest, then quicker would be to go there instead of asking here;-)
    You don't have to buy it again :-)

    With kind regards.
  • AirAir
    Posts: 10,000
    AlexNavas said: Is there a way to customize the size of the featured image in the Post Grid so they look like your previous version (which are the same as the similar posts sizing on single posts).
    I have checked and there is no way, without rewriting lot of VC code, to do it as you want. They did it, so it would be as responsive as possible and it is main problem. However you can try few half solutions:
    1.

    .vc-gitem-zone-height-mode-auto::before {
    padding-top: 50%;
    }
    result:
    image

    2.

    .vc_gitem-zone {
    background-size: contain;
    }
    result:image

    You can also try to combine both or work with position of images in second case.

    With kind regards.
    s.png
    1242 x 403 - 468K
    2.png
    1175 x 736 - 603K
  • I read through this discussion and found a couple of the same issues Alex is experiencing with the new theme. First, when I make changes to existing pages they are not committing. This is possibly because of the old PHP, I'm aware I'm running old PHP, we've talked about it previously. Also, when I set a full width background on a row, it doesn't show. I can see that the background image loads for a split second, but then I'm guessing the browser loads the rest of the CSS and repositions it.
  • AirAir
    Posts: 10,000
    Hi there:-)

    I made this topic only to inform about return of Superior and what changes are required if you want to use it.

    I appreciate all feedback about issues, but please do it classic way: one issue per each NEW topic :-) This way we can actually try to investigate each thing.

    It is needed even more cause most of things I can't recreate on my setup. It just works fine for me:-)

    With kind regards.
  • Posts: 25
    Hi, I just update the theme and after reviewing all the updates, i can't find the solution for the short-codes of recent or latest post. when I add the widget it only show simple lines but i had 1 column with image something like this
    http://superior.theme.apollo13.eu/blog-features/blog/
    why the shortcode is not working now and/or what is the solutions since the widget is not giving me the option to select what type i need.
    Thanks
    Fabiola
  • AirAir
    Posts: 10,000
    Hi there:-)

    Please read my first post in these thread. Superior 2 does not have old shortcodes from old visual composer, as new Visual composer dont have them:-)

    Our current demo is under this link btw. http://superior.apollo13.kinsta.com/

    The look that you wish to achieve is only possible now with dedicated blog page, posts shortcodes look like on screen shots in above posts.
    If you don't like it then I advise to return to Superior 1.9.X

    With kind regards.
Sign In or Register to comment.