Before you ask please READ THIS

Menu items: it shows only icons, not label

Hi guys,
we installed your theme and imported demo contents here:
We noticed menu shows only icons and not label.
We could help us to fix it?
Thanks
Schermata 2018-03-06 alle 13.20.38.png
2880 x 1800 - 3M

Comments

  • here settings for menu, as you can see we set correctly hover effect
    Schermata 2018-03-06 alle 13.46.49.png
    2880 x 1800 - 940K
  • AirAir
    Posts: 10,889
    Hey there:)

    In customizer view it can happen that all menu options are active, cause WordPress marks them in wrong way in customizer view.

    However in normal viewing it should be fine. As your site is blocked I suspect it could be some plugin messing how classes are applied to menu by WordPress.

    Could you try testing it when site is normal, non maintenance mode?

    With kind regards.
  • Hi!
    we switched off maintenance mode...but problem is still there.
    You can see it
  • AirAir
    Posts: 10,889
    I have just tested it on FireFox and Chrome and it works as it should - labels visible.

    On what browser do you view it?

    With kind regards.
  • Hi,
    you can see here: https://www.screencast.com/t/CWlanI1LajI

    We tried with all our browsers and just one is showing labels...but in a strange way.
  • AirAir
    Posts: 10,889
    Hello again :-)

    Thanks for movie. Still it doesn't bring us closer why I see it fine, and you don't, but we will figure it out:-)

    I have been again on your site and I see last 3 section as icons, cause there are no such sections on site. You must have removed them, so we can ignore them for a moment.

    Could you tell are you logged in to WordPress on those browsers? Cause we may see different things if you have some cache plugin there for example.

    Another idea - turn off google maps plugin, as there is error in console about invalid key for map - there is a chance that is crashes JavaScript.

    About "strange way" in Firefox developer edition - it works there as intended, same as on our demo. It highlights all sections that are currently visible on screen.

    With kind regards.
  • I have been again on your site and I see last 3 section as icons, cause there are no such sections on site. You must have removed them, so we can ignore them for a moment.
    Yes, we removed them

    Could you tell are you logged in to WordPress on those browsers? Cause we may see different things if you have some cache plugin there for example.
    We were logged in only on Firefox, not in Safari/Chrome/Firefox Developer.

    Another idea - turn off google maps plugin, as there is error in console about invalid key for map - there is a chance that is crashes JavaScript.
    Turned off...but nothing happens.

    About "strange way" in Firefox developer edition - it works there as intended, same as on our demo. It highlights all sections that are currently visible on screen.
    Ok

    We'll probably remove the hover effect, because looking better at it, we don't like it so much.

    However...thanks!
  • AirAir
    Posts: 10,889
    brandingaddicted said: We'll probably remove the hover effect, because looking better at it, we don't like it so much.

    However...thanks!
    Haha, that is also solution, but mystery remains;-)

    I believe that was something on the line of cache, but would need access to your setup to test it, and what more - I would actually need to see it :-) Cause right now I see it in correct way.

    Hope I could be more help in any other case :-)

    With kind regards.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!