Before you ask please READ THIS

PHP Fatal error: Uncaught Error: How to fix?

in FatMoon Posts: 3
I 'm using HostGator with their Optimized Wordpress host. I'm able to install FatMoon and work with it as long as I stay in my WP Admin mode. Once I log out and try to login I get this error:

This page isn’t working " ".com is currently unable to handle this request.
HTTP ERROR 500

By FTP I'm able to find this in my error log:

PHP Fatal error: Uncaught Error: Call to a member function set_settings_set() on null in /home3/waiup20afk6c/public_html/wp-content/themes/fatmoon/advance/theme-options.php:13

All plugins are installed and work fine without FatMoon activated.
The only way I'm able to get back into WP Admin is to change or delete my FatMoon folder name.

Any ideas?

Comments

  • AirAir
    Posts: 9,694
    Hello :-)

    First time seeing such error.

    Could you first by deactivating all of your plugins except for Apollo13 Framework Extensions.

    If it helps, then reactivate plugins one after another until you hit problematic one.

    Please let me know how it went.

    WIth kind regards.
  • Posts: 3
    Actually I discovered a solution... just bypass my entry through HostGator.... seems all is well if I enter WP Admin directly. For now I'm fine with this. Yet it's a rather annoying quirk. Thanks for responding.
  • AirAir
    Posts: 9,694
    Thanks for the info!

    Could you give me more details about how you were entering your site when the error occurred?
    I would love to provide some solution or permanent fix, but I need to know what we are facing here :-)

    With kind regards.
  • Posts: 3
    Hi
    As I mentioned earlier, I'm using HostGator with their Optimized Wordpress host.

    This service only allows access to WP Admin. from a hosting page. This area allows me to set up email, ftp accounts etc. There is no cPanel. I am able to create a working ftp account.
    When I select WP Admin, there is a redirection redirect=/hosting/wordpress/141595/sso
    The page comes up as a HTTP error 500

    I'm using Chrome Windows 10. But I recently tried the Microsoft Edge browser and I get the same error. It was a long shot, but I thought maybe there was a browser conflict issue....
    Please don't feel a strong need to solve this, I'm perfectly fine with a direct link to my WP admin. without going through HostGator. This is obviously not a common problem and shouldn't reflect on your theme.... which by the way, I like very much. I'm liking the results I have so far.

    Richard
  • AirAir
    Posts: 9,694
    Hey :-)

    Thanks for the detailed answer!

    I will have to run a test account on host gator and check this out. Sounds very strange that this happens, like it was skipping some theme files.

    I will add it to my todo and check it whenever possible.

    Thanks once again!

    PS. Browsers conflict check in case of PHP error - it really COULD happen, when cookies would be involved for example. So such things happen, however extremely rarely.

    With kind regards.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion