Before you ask please READ THIS

Font sizes in Works Lightbox

in OneLander Posts: 13
Hello,

I have OneLander version 2.4.0 installed on WordPress 5.2.1.
I have elected to import the 3rd theme and it works fine.

The majority of the project is complete, however our client desires a larger font size for the text inside of the Works Lightbox.

I could not find any documentation nor configuration settings that allows us to change this setting. We can increase the size of the font by changing from paragraph to heading, but this results in all capital letters.

I would appreciate some help in identifying the location of the appropriate menu items.

Thanks in advance for your assistance!

Comments

  • AirAir
    Posts: 9,964
    Hello :-)

    Works lightbox doesn't have any settings in theme options, but I can help you with custom CSS to change this.
    Please mark on the screenshot which parts you want to edit and I will prepare custom CSS for you.

    With kind regards.
  • Posts: 13
    Hi Air,

    When you navigate to the works tiles and select one, it is going to bring up a lightbox with the title and content. I would like to increase the size of the font related to the content.
    Please see attached image with the area that change is required inside of the red box!

    I could see where I could change the font type, but nothing about the size...
    We also tried to write CSS to change the font, but it was not taking standard CSS commands or perhaps we were putting it in the wrong CSS area...

    Thank you for your support!
    snapshot.jpg
    1366 x 728 - 149K
  • AirAir
    Posts: 9,964
    Hey :-)

    Please add this Custom CSS( https://rifetheme.com/help/docs/customizing-the-theme/custom-css/ ):
    .a13-post-lightbox-content .work-content{
        font-size: 20px;
    }
    
    This should help :-)

    With kind regards.
  • Posts: 13
    Thanks for taking the time to get back with me. At first glance I could not see any changes, so I changed the 20px to a 50px to see what is actually changing.
    The CSS provided increased the spacing between the lines, but did not increase the size of the font itself. Are there additional changes required to make that work? Should I be loading any fonts other than what comes as default?

    Here is a snapshot with the CSS in place (at 50 px).

    Thanks again for your help and assistance!
    snapshot2.jpg
    1366 x 728 - 126K
  • AirAir
    Posts: 9,964
    Please send me a live link to installation where it happens. It seems that something else is interfering.
    If you need you can do it by private message(click on my nick, in top-right corner you will find option "Message")

    With kind regards.
  • AirAir
    Posts: 9,964
    Thanks for the link in the private message.

    Where have you added custom CSS that I have provided because I don't see it on your page?


    With kind regards.
  • Posts: 13
    I have now put it back in again for your review, but it did not seem to resolve the problem.
    It looks like it is only increasing the spacing between lines and not increasing font sizes.

    Your assistance in resolving this issue would be highly appreciated.
  • AirAir
    Posts: 9,964
    I have just checked and CSS works fine in Chrome and Firefox - Fonts are bigger.
    What browser are you testing in?

    Only thing is that in our theme the first paragraph of the content is higher(1.1 times bigger) than the rest of the paragraphs, but you can disable it in:
    Customizing → General settings → Content → First paragraph : Highlight → Disable

    With kind regards.
  • Posts: 13
    Air, Thank you for your support.
    I upgraded my chrome to the latest version and it seems to be increasing the font now.

    It is also increasing spacing, making it less than attractive. Is there a way to control the unwanted line spacing in the works lightbox?

    I appreciate the CSS you sent!
  • AirAir
    Posts: 9,964
    Hey:-)
    ryazhari said: I upgraded my chrome to the latest version and it seems to be increasing the font now.
    That is great!

    ryazhari said: It is also increasing spacing, making it less than attractive. Is there a way to control the unwanted line spacing in the works lightbox?
    You can set line height to fixed size with this custom CSS:
    .a13-post-lightbox-content .work-content .real-content{
        line-height: 36px;
    }
    With kind regards.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion