Before you ask please READ THIS

Streaming video at the top is not working on mobile devices

in OneLander Posts: 9
I have OneLander version 2.4.0 installed on WordPress 5.2.1.
I have elected to import the 3rd theme and it works fine on desktop products.

On mobile devices such as iPAD (with latest Chrome) or Samsung Galaxy S cell (with latest Chrosme), the video at the top does not load or stream.

Are there settings to enable the streaming on mobile devices?
If so, please share your knowledge...

I also saw another post similar to this but it was old so I was asked to open a new discussion.

Thanks... Your thoughts would be highly appreciated!

Comments

  • AirAir
    Posts: 9,868
    Hey :-)

    I don't see any video in the 3rd demo, so you will have to post a live link to your site.

    If you want to autoplay video with sound, then you have to know that Chrome has invented a policy where it prohibits auto-playing videos with sound on webpages. Only muted video can autoplay.

    More info here https://developers.google.com/web/updates/2017/09/autoplay-policy-changes

    With kind regards.
  • Posts: 9
    Well, this is the same video that the template demo maps to.
    The imported demo (number 3) as well as the Envato demo both play that video (mutted).
    It should be easy to find as it is where the slider would be at the vert top of the page.

    If you cannot find it, I can share a link to either our website or the envato demo if I can do so privately. Here is a snapshot of the page configuration:

    Thanks for any guidance you can provide!
    snapshot.jpg
    1366 x 728 - 141K
  • AirAir
    Posts: 9,868
    I will need a live link like in your other topic :-)

    With kind regards.
  • AirAir
    Posts: 9,868
    Hey :-)

    Sorry for missing this earlier, as indeed it works the same on our demo.
    It looks that is the limit of Elementor, that video is only played on bigger devices, probably to save CPU of smartphones.

    You can find few discussions about it like here https://wordpress.org/support/topic/background-video-problem-with-elementor-plugin/

    There is nothing I can do here to help you here.

    However, I suggest adding a placeholder image, like in our demo, that will be shown for smaller devices.

    With kind regards.
  • Posts: 9
    Hi Air,

    Thanks for confirming this issue and for getting back with me.
    I am not sure how our client would feel about this until I bring it up to them.
    I do need to have some more information before I open that conversation.

    Would the same issue occur if we upgraded to Elementor Pro? would that resolve the issue? If not would WP Bakery page builder work?

    There isn't enough time for us to migrate to another page builder as we would have to recreate the whole thing all over again, but I need to know our options.

    Thanks!
  • AirAir
    Posts: 9,868
    Hello:-)
    ryazhari said: Would the same issue occur if we upgraded to Elementor Pro?
    I don't know that, but I expect it will be the same, as like I have said, they probably had a reason for that(save CPU of smartphones).

    You would need to talk with the Elementor team to get more info.
    ryazhari said: If not would WP Bakery page builder work?
    I don't know. I think it worked in the past, but they might have change it like in Elementor case. This is a question to WPBakery team, sorry.

    In my opinion this is decison made to force users to be responsible with their desings, and not overload devices with effect that drain battery of smartphone

    With kind regards.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion