Before you ask please READ THIS

Bug at Writing Effect Since Update to WP 5.2.4 ?

edited November 2019 in PhotoProof Posts: 87
I'm deeply sorry having to report one more time a problem.

I just noticed there is something wrong with the writing effect, since update of WordPress 5.2.4. The writing effect in general works. However, prior the text having the writing effect, the tag displays the text once again, but static.

It's no corrupted file. It's in both files w/o me touching these. Thus the only explanation would be the update to 5.2.4, as nothing else has been touched (except for eliminating the Google Web Fonts with the $handle code in functions.php of course).

Send you login details so that you can see by yourself.
Post edited by MLG76 on


  • AirAir
    Posts: 10,567
    Hey :-)

    Please try to remove this code from yesterday and we will check.

    The reason that you see sentences doubled, is that there is not removed .no-js class from body element, that is importatnt to check if JavaScript is enabled in the client browser. However, here this check fails for some reason.

    With kind regards.
  • AirAir
    Posts: 10,567
    OK. I didn't notice that this code for changing this class was in the code for webfonts. Let me think about some solution :-) I will post soon.
  • AirAir
    Posts: 10,567

    The yesterday code change to:
    add_action('after_setup_theme', function(){
        remove_action( 'wp_enqueue_scripts', 'apollo13framework_get_web_fonts_static' );
    Next, go to Appearance → Customize → Miscellaneous Settings → Use the web-font loading script → Disable.

    Now it should be fine and GDPR friendly.

    I will post same solution to your other topic.

    With kind regards.
  • edited November 2019 Posts: 87
    Air, once again thanks for fixing things that quickly! You are indeed faster than real Apollo13 space ship. ;-)

    I can confirm, the fix works! The writing effect is now back as it should.

    The only thing I noticed is, once you disable the web-font loading script as described above, within the 'Customize'-panel preview window the text is not visible for some second and afterwards all texts change to some default system font. Is that the price I got to pay once working with local fonts or shouldn't it be like that? Just thought I better mention this ... ;-)

    Post edited by MLG76 on
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!