Before you ask please READ THIS

Woocommerce product archive thumbnail mess

edited November 2016 in Fame Posts: 62
Hi Air,
I hope you are doing well. After updating to the new woocommerce, the size of my thumbnail on product archive is not the same on every products anymore..? so that it looks messy.. How and where can I change this?
I'm working on a child theme. In my child's product-content.php, I have the following code:

    //thumbnail
    echo '
    <div class="thumb-space">
        <a class="thumb" href="'.get_permalink().'">';
            //main thumb
              $img_size = array(229, 180);

            echo woocommerce_get_product_thumbnail($img_size);
Many thanks in advance for your help :-)
Best
screenshot-13-nov-2016.jpg
2496 x 1524 - 559K
Post edited by Air on

Comments

  • AirAir
    Posts: 9,696
    Hi there again:-)

    From where do you have such code?
    If you remove it does it work better?

    I think you should change images sizes for woocommerce from its settings https://docs.woocommerce.com/document/using-the-appropriate-product-image-dimensions/

    With kind regards.
  • edited November 2016 Posts: 62
    Hi Air :-)
    this is from woocommerce content-product.php
    if I remove the code I don't have thumbnails anymore on my product archive.... :-/
    I'v already try to change the image size in the woocommerce settings but nothing change even with regenerate thumbnail...
    I now did override the above code with your "standard" code:

    -- CODE REMOVED--

    but still a mess AND I now have image sizes that doesn't fit my needs at all (as you can see on the screenshot attached) :-(

    Please let me know how I can define an image size for all my thumbnails?

    Many thanks in advance for your help
    screenshot-14.11.2016.jpg
    2416 x 1500 - 749K
    Post edited by Air on
  • AirAir
    Posts: 9,696
    I believe that if you will remove whole this file from child theme, and then set sizes in woocommerce settings with crop enabled, and then regenerate images, then you should have it best way.

    I don't know how it looked on your page previously. However there wasn't any changes in that matter recently in WooCommerce or theme, so it probably wasn't working for longer time.

    With kind regards.
  • Posts: 62
    Hi air,
    Many thanks for your reply. Crop was always enabled..
    So I'v removed the file from the child theme, and the issue is still there. I'v tried to indicate thumbnail size in the woo commerce setting with crop enable + regenerate and absolutely no change at all...
    so the issue doesn't seem to come from this file....
    I'v now restored the code I'v copied you above (the one with array) since it was the best looking "mess" so far and every other solution didn't work either..
    Before I'v noticed this issue every thumbnail had the same size on my website. It's possible that it was there before the latest update, since I wasn't much online the last 2 weeks. But what can I do??
    Help ;-)
  • AirAir
    Posts: 9,696
    Well, you are right that might not be that file(i am not sure here). What other files do you have in child theme?
    Safest test would be to switch no full theme, do regeneration of images, and see if it would work. If not then issue is somewhere else.

    With kind regards.
  • Posts: 62
    this has nothing to do with the child theme, since I'v tested with Fame theme and also Fatmoon (free trial - I was considering it for a future purchase ;-)) and the issue is the same on all of them....!!
    on all the tests I did regenerate thumbnails. But the bug is still there :-/
    Any clue?
  • AirAir
    Posts: 9,696
    That is kind off odd. Would you mind if I would make my tests on your installation? Maybe when I will focus on your case from code perspective I will notice something obvious:-)

    Could you please send me temporary access to your WordPress and FTP so I could check there what is going on? Send it here on forum via private message(click on my nick, in top-right corner you will find option "Message"). In message please attach LINK to topic it applies to.

    By sending access to WordPress I mean:
    -create new ADMIN account with fake e-mail
    -set some password to this account
    -send me created login and password

    With kind regards.
  • Posts: 62
    Hi Air,
    well I'v found out what created the thumbnail mess. I'v installed the Jetpack plugin by wordpress.com last week and this caused the issue. I deactivated it and it's now working as before!
    After this hassle I did some experiments as I wanted to change the thumbnail size, I went through the woocommerce settings + regenerate thumbnail process and no way to change thumbnail sizes :-/ again I'v tested with Fatmoon (to be sure it's not my child theme fault) and it doesn't work either. Would you like to have a look even if the bug of different thumbnail sizes is now detected and solved? Let me know and I'll prepare you the access
  • AirAir
    Posts: 9,696
    Hi coris:-)

    Thanks for that info, I will check it out soon, and verify what is going on. Do you which part(module) of JetPack is creating this issue?

    In that case I don't need access for now, so just move on with your work.

    With kind regards.
  • Posts: 62
    Hi Air, no unfortunately I don't know what part caused the bug.. I'v deactivated the whole plugin and it worked.
    Best
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!