Before you ask please READ THIS

Header Menu Bug - Duplicate Flag

in Photon Posts: 67
Hi,

Already a few Photon versions old, but I have an issue with the Header menu on the top bar using WPML with this template.

If I deactivate all plugins on the website except the WPML Multilingual CMS I still have the issue. It also happens with the minimal additional 3 plugins that go with your theme.

This means that I have the country flag and language as well as the WPML dropdown in the header.

Is this easy to fix? It only started happening after updating versions not changing parameters.

Thanks in advance.

Alistair
20170619 Menu Image.PNG
1077 x 182 - 46K
20170619 Active Plugins.PNG
1303 x 288 - 40K
20170619 Language Switcher Settings.PNG
1005 x 768 - 41K

Comments

  • AirAir
    edited June 2017 Posts: 9,692
    Hello there:-)

    Long not seen here !
    Alistair said: It only started happening after updating versions not changing parameters.
    I have some questions:
    1. After updating of what? WPML or theme?
    2. Is it actually visible on your site? Link to site please.
    3. Can you tell on which theme version it works proper or you don't know that?
    Alistair said: Is this easy to fix?
    I don't know yet :-)

    With kind regards.
    Post edited by Air on
  • Posts: 67
    Hi Air,

    It has been a long time indeed. It all runs smoothly and any bugs are generally not yours anyway. :-)

    In answer to your questions:

    1) It was a long time ago but I'm certain it was after updating the theme.
    2) Yes, visible on site. Link is www.alistairjamesbell.com (sorry, thought I'd sent it already).
    3) Not sure which theme version it worked on last but possibly 3 versions ago.

    I did log the call in parallel with WPML in case it was not your issue and they have come back with the following which may help:

    It seems that the first element is coded in the theme's header.php file. However, you can avoid duplicating using simple CSS trick.

    You should go to WPML > Languages and under Additional CSS paste this code :

    #menu-item-wpml-ls-46-en {

    display: none;

    }

    #menu-item-wpml-ls-46-fr {

    display: none;

    }

    #menu-item-wpml-ls-46-it {

    display: none;

    }

    Hope it all helps.

    Cheers,

    Alistair
  • AirAir
    Posts: 9,692
    I don't have access to newest version of WPML, but I tested it with newest Photon and I can not recreate issue.

    I suspect it maybe something else that si interfering.

    Please tell me - if you disable this language switcher in WPML settings does both disappear ?
  • Posts: 67
    Hi There,

    It would seem the problem is caused by a change to WPML in the end.

    I couldn't find a way of disabling the language switcher in the setting so I deleted the "Menu language switcher" in the settings (see screen shot).

    By doing that there is still a language switcher on the website but the "malfunctioning one" has disappeared.

    Took the opportunity to test with the new version of Photon as well and all is good.

    I'll go back to WPML and point this out to them.

    Thanks as ever. It's nice to see your as reactive as always.

    Alistair
    20170623 WPML Settings.PNG
    1169 x 674 - 69K
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion