Support will be limited from 22.05.2019 till 26.05.2019

We will answer all the questions from that period after we get back on 27.05.2019.

Have a great rest of May ;-)
Apollo13Themes Team
Before you ask please READ THIS

Blog sidebar always on the bottom

edited April 2018 in Photon Posts: 36
Hi,

I've tried to change the settings in 'Pages' view but doesn't matter which option I use the sidebar always appears at the bottom. Example link below

http://www.varmode.com/fashion/nike-air-max-90-id-air-max-day-2018
Post edited by SidhuR on

Comments

  • AirAir
    Posts: 9,802
    Hey :-)

    I see you have PHP warnings displayed on your site, and I believe this might be the reason. Please disable debug mode https://codex.wordpress.org/WP_DEBUG#Usage

    For me your sidebars display on right as it should.

    With kind regards.
  • Posts: 36
    Hi, Thanks for your response. The below is the error message I am getting on the front page.

    Warning: count(): Parameter must be an array or an object that implements Countable in /home/varmod5/public_html/wp-content/themes/photon-a13/advance/meta.php on line 239

    Warning: count(): Parameter must be an array or an object that implements Countable in /home/varmod5/public_html/wp-content/themes/photon-a13/advance/widgets.php on line 106

    Is there an easy way to disable the debug mode without amending code as I am not familiar with that ?

    Regarding the sidebar I have used Safari and Internet Explorer and for the below post page and also the Blog page they do not seem to change when I change the page settings.

    Blog Page : http://www.varmode.com/see-live-be-blog-news
    It stays on the left hand side when I want it on the right hand side and this is what it is set to on page set up.

    Post Page: http://www.varmode.com/art/takashi-murakami-x-virgil-abloh-future-history-exhibition-gagosian-gallery
    It appears on the bottom of the page rather than the right hand side
  • AirAir
    edited April 2018 Posts: 9,802
    You have to disable debug mode in wp-config.php as explained in link. It is not safe to have it active on production site. It can be also reason of issues that you face currently.

    After you will do it I will continue to investigate your topics:-)

    These warnings come from theme, as it seems you have upgraded your PHP version to 7.x. It looks that Photon theme have few issues with this version.

    I don't know when I will be able to update it, as Photon is no longer supported, and I have so much on a plate right now. But I will add it to my meters long TODO:-)

    With kind regards.
    Post edited by Air on
  • Posts: 36
    Hey, thanks for replying.

    I have downgraded php version and that fixes the error messages I was seeing.

    I checked debug mode in wp config file and it is already set to false.

    Looks like issues resolved
  • AirAir
    Posts: 9,802
    Good to hear! Thanks for feedback about this:-)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion