Before you ask please READ THIS

WPML Language switcher don't show second language

in Starter Posts: 13
Hello,

My website is a one pager, I use WPML and there is a menu in my 2 languages.

WPML is configurated to add language chooser at the end of my principal menu. In my WPML configurations:

If I choose List of languages, I see the two languages in the website.

If I choose Drop down menu, I only see actual language in the website, I’m not able to see the other language in drop down but I want to use drop down menu to save space.

How can I activate the drop-down menu to see the second language in a one-pager version?

To see my Website:

http://navanex.audace.qc.ca/
http://navanex.audace.qc.ca/?lang=en

Navanex / Ch@ntierN4val

Regards,

Mario

Comments

  • AirAir
    Posts: 10,138
    Hello :-)

    Please check if opening icons are activated in theme settings:
    Appearance → Customize → Header Settings → Main Menu → Submenu/Mega-Menu : Opening/Closing icons

    With kind regards.
  • Posts: 13
    Hello!

    It's actually activated. :(

    Any other suggestion?

    Regards,

    Mario
    Capture d’écran, le 2019-07-31 à 08.50.44.png
    590 x 2268 - 198K
  • AirAir
    Posts: 10,138
    OK.

    Please update the theme, as in recent version I have made fixes to this dropdown, and your version could still be affected by old code.

    With kind regards.
  • Posts: 13
    I am currently using a child theme of what I think is the latest version 2.4.2

    Regards,

    Mario
    Capture d’écran, le 2019-07-31 à 09.40.12.png
    1320 x 846 - 162K
  • AirAir
    edited August 1 Posts: 10,138
    Hello :-)

    Like I have said please update the theme, as the most recent version is 2.4.4.3.

    With kind regards.
    Post edited by Air on
  • Posts: 13
    Hello,

    Yes! It's works well!

    Really sorry! I thought I had the most recent version.

    I had to update the theme manually by FTP and now it' akay.

    Many thanks to you! :)

    Mario
  • AirAir
    Posts: 10,138
    Hello :-)

    Great to hear that. Thanks for the feedback!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion