Before you ask please READ THIS

Password Protected Page not working + Where do I find password form?

in PhotoProof Posts: 47
Hello,

having a problem I'm unable to resolve.

My "protected page" looks weird for unknown reason [1].

I haven't touched this file since installation. Upon inspecting it now, I noticed it's not looking nor working as it should.

First problem: I cannot remove the white background within Elementor to make the page transparent. Second problem: I don't see any password form to enter my data. Third problem: If I add a password for test purpose in WP admin GUI, the page loading gets stuck and Elementor asks to go into stable mode. I tried to create a brand new page, as described in the documentation. However, that also doesn't solve the problem. I'm already struggling in finding the password form in Elementor to paste in. I haven't touched the settings @ Customize -> Pages -> Password Protected Page. Those are on default settings.

What am I doing wrong?

The "protected album" as a comparison works fine btw [2].

Thanks very much for any help on this.

Best regards
Marius

[1] https://lange-grumfeld.photo/protected-page/
[2] https://lange-grumfeld.photo/album/photo-proofing-iii/

Bildschirmfoto 2019-10-10 um 16.18.50.png
634 x 900 - 171K

Comments

  • AirAir
    Posts: 10,143
    Hey :-)

    The password form part is not available in Elementor. This cames natively from WordPress, so it is added after your content always.

    It is explained here https://rifetheme.com/apollo13-framework/docs/customizing-the-theme/page-settings/passwords-protected-page/

    So when you will view page set as "password protected template" you will not see the form. However, when the password-protected album will load this template, there will be a password form at the end.

    As for background color - it comes from the theme. However, when the password-protected album will load this template there will be no background color(transparent).

    Sorry if this is confusing, but WordPress didn't make it easy to customize password protected part ;-)

    With kind regards.
  • edited October 10 Posts: 47
    Hi Air,

    I read this article in the documentation in advance. But based on that, that wasn't clear to me.

    However, it's not really working as supposed for the page-version. As soon as I set a password there via WP admin panel (I've used "demo" for test purposes for the moment), the site doesn't load anymore. I get a time out. Neither I can view the page in a browser, nor edit the page anymore with Elementor. Give it a try by yourself [1].

    Before we waste our time on searching what's wrong... Is there any simple way to patch this (e.g. by overwriting my existing protected-page file with the original default file)?

    Kind regards
    Marius

    PS: Congratulations to your country winning nobel prize!

    Post edited by MLG76 on
  • AirAir
    Posts: 10,143
    Hey :-)
    MLG76 said: Before we waste our time on searching what's wrong... Is there any simple way to patch this (e.g. by overwriting my existing protected-page file with the original default file)?
    Did you edit the theme file for this? Or do you mean to revert back original template from Elementor for password protected page?

    If the later one, then If you have edited imported page, you can revert back by using Revisions tab in Elementor while editing page https://docs.elementor.com/article/104-history

    With kind regards.
  • Posts: 47
    Yes, the original theme file, which is stored in section 'Pages' as file 'Protected Page' (I haven't figured out yet how to duplicate such files, to make my own while keeping a backup). I meant restoring that file 'Protected Page' to the state of a brand new installation, so how it came from you originally.

    Thanks for the Elementor article. I have checked that revision already and reverted back to the earliest state available there. That page version (initial version?) loads normal if no password is set. However, as soon as I set any password, the page load gets stuck. So it doesn't work neither with that file revision.

  • AirAir
    Posts: 10,143
    Could you please send me temporary* access to your WordPress so I could check there what is going on? Send it here on the forum via private message(click on my nick, in top-right corner you will find option "Message"). In message please add LINK to topic it applies to.

    By sending access to WordPress I mean:
    -create a new ADMIN account with a fake e-mail
    -set some password to this account
    -send me created login and password

    *temporary - please delete this account after I am done, for your safety!
  • AirAir
    Posts: 10,143
    Hey :-)

    Thanks for the data. Everyhting works fine for me.
    MLG76 said: However, as soon as I set any password, the page load gets stuck. So it doesn't work neither with that file revision.
    Do you set this password on the Album or on the page that is named password protected?

    I am asking because the album https://lange-grumfeld.photo/album/photo-proofing-iii/ opens fine after proving "demo" password, that is set for this album.

    Generally, each album should have a different password, and this "demo" password written on the page that is named password protected is for demonstration only. You should change this text to something more generic.

    I believe there was some misunderstanding.

    If you will set a password on the page that is used for password-protected page it must fail as it will lead to infinite loop:-)

    With kind regards.
  • Posts: 47
    Hi Air,

    thanks very much for checking the configuration.

    I have set this for the page which is password protected. I haven't touched the album. Yes, the album opens fine after proving "demo" as password, which is set for album. The infinite loop is exactly what occurs.

    Well, but then I'm not understanding the sense of the password protected page. What's its mission? Maybe there is indeed a misunderstanding.
    My current understanding is, I can 1. use the protected album for proofing, setting individual passwords and/or 2. a password protected pages with also individual passwords - both totally independent from each other.
    How to set the password for the album was clear to me, as "demo" was preconfigured within the theme. Thus I tried to do the same with the page in order to see how I can make use of that within my site... and ended up in the infinite loop.

    Kind regards
    Marius

  • AirAir
    Posts: 10,143
    Hey :-)
    MLG76 said: My current understanding is, I can 1. use the protected album for proofing, setting individual passwords and/or 2. a password protected pages with also individual passwords - both totally independent from each other.
    1. You can set passwords for albums - that is clear.
    2. The page named "password protected" is a template of how a website will look when you will lock anything under password(post, page, album or work). So it is used only for design.

    When WordPress finds out that for example Album(that you try to view) is locked under password, then before displaying album it will display above mentioned page on which the user can provide a password to enter the requested album.

    In other words - the "password protected" page helps you personalize a bit this "password asking" screen.

    You can even change this page to any other premade page in Appearance → Customize → Page Settings → Password protected page template .

    I hope it is a bit clearer now.

    With kind regards.
  • Posts: 47
    Hi Air,

    okay, now I understand. Thank you very much for clarifying this. I already had the feeling yesterday it might be just a linked template, sitting there.

    I hope you don't mind, if I would like to throw in a recommendation then. In order that none might be stumbling over this (like I did) in future, I suggest to make the name of that particular page more clear (e.g. changing it from Password Protected to something like "password protected prescreen"?). Additionally a bid more beef within the respective points of the documentation would be great.

    Thanks very much once again for all your help.

  • AirAir
    Posts: 10,143
    Thanks for your suggestion!

    I am glad that this situation is solved.

    With kind regards.
  • edited November 25 Posts: 47
    Air, pls apologize if there is one more question reg. this topic …

    I’ll have to admit, this page really drives me nuts. :-/ ;-)

    Based on your prior answer and reading the documentation at least five times carefully since then, I understood the process logic, that first you get ‚Protected Page‘ and upon successfully entering credentials ‚Protected Album‘ gets displayed. So far so good.

    Now I've tried to harmonize ‚Protected Page‘s design to integrate that smoothly into my overall site look & feel. However, settings seem to have no effect or are simply not possible. Maybe I’m simply too stupid for this page. I also notice weird behavior, which I cannot root cause to caching.

    On Friday I tried to twiddle with the header settings. What ever I selected (dark, light, normal, global), it never worked as it should. Either things where with black or white background (while menu text was not inverted) or menu was displayed correct only once I scrolled down and went back (was reproducible). I documented my changes and put everything back as it was. What I couldn't heal was that the box where to enter the password was used to be displayed twice. The second box was a little lower and could be seen on larger displays only once you scrolled.

    Today I wanted to continue. What I saw was different to Friday. Now the box where you enter the credentials is completely gone and there is a white box above the background image. The page on Friday was definitely w/o a white box and yes, I've cleaned my caches. However, the page background setting is empty. So there should be just the default greenish background and the box visible, shouldn’t it?


    Post edited by MLG76 on
  • AirAir
    Posts: 10,143
    Hey :-)

    Are you working on the original template for password protected that came with the page, or you are making your own from the scratch?

    I can not fully visualize what issues you are facing, so it would be great to add screen shots as well.

    With kind regards.
  • Posts: 47
    Hi Air,

    thanks very much for your help.

    I'm working with the stock template as it came with the original theme. I've made a clean installation for the final website, in order to make sure not to inherit any eventual problems. I was really after not touching at, as I was already a bid freightened. So I made a big round around it and wanted to work on it not earlier then when everything else is set.

    Have attached a screenshot.

    Bildschirmfoto 2019-11-25 um 17.39.23.png
    2742 x 1670 - 998K
  • AirAir
    Posts: 10,143
    Hey :-)

    I have spend some time on this on your website.

    It seems deactivating "WP Meta SEO" plugin solves the issue.

    Remember to test preview on the protected album, not on that page that you are desiging. I know, it is a bit crazy:-)

    https://yoursite.photo/album/photo-proofing-iii/

    With kind regards.
  • edited November 25 Posts: 47
    Thanks for your help once again.

    Have deactivated 'WP Meta SEO' (used it only to speed up altering the meta texts).

    Finally I now remember, why I couldn't reproduce the second credential field problem earlier this day. It was because I've opened the page instead of the album. Will test only with the album from now on.

    For 'Protected Page' I've set now at "Hide content under header" the setting "Turn it off", so that this large headline is no longer shown. Like that things are fine for me. Changing the header now also works as expected.

    One more question: As soon as I enter the password and login, the browser never asks for it again but shows me immediately the protected album - even if I delete my cache. Not sure if that is Mac-specific. But where does it store it? I've checked my Mac's keychain, but it's not saved there as password. I also couldn't find any setting in WP. My workaround was to set a new and set it afterwards back to "demo", which worked.

    Post edited by MLG76 on
  • AirAir
    edited November 26 Posts: 10,143
    Hello :-)
    MLG76 said: I also couldn't find any setting in WP
    This is purely WordPress mechanism. As soon as you provide valid password, cookie is created in your broswer that will not ask for a password for this post again.

    What is more, if you add the same password("demo" in this case) for other pages/posts/albums, then all of them will be unlocked at once, as cookie is already created.
    More details here https://kinsta.com/blog/password-protect-wordpress-site/#post

    With kind regards.
    Post edited by Air on
  • edited November 27 Posts: 47
    Thanks for this informative article.

    Is that cookie a technical 'must have' to use the password protection? If not, how can I pull its plug? You might know why I'm asking. It's because of latest GDPR requirements. I would like to work w/o these annoying cookie consent banners.

    Post edited by MLG76 on
  • AirAir
    Posts: 10,143
    Hey :-)

    Sorry, but I don't know any details about this. This is the default WordPress part, not really part of the theme. You would have to ask about it on a general WordPress forum and how it affects GDPR.

    With kind regards.
  • Posts: 47
    Okay, no problem. Makes sense. Will check that out.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion