Before you ask please READ THIS

Making Google Web Fonts local - Part 2

in Rife Posts: 87
Hello Air,

almost finished! ;-)

Question: Has there been any changes regarding how to remove Google Web Fonts and making those local compared to what you advised one year ago for PhotoProof here [1]? I'm asking, as I've proceeded exactly as suggested. However, it's yet not working on the new site [2].

https://webbkoll.dataskydd.net reports Google Web Fonts are still somehow loaded, which causes a GDPR problem of course.

Will send login to site via PM.

Thanks very much,
Marius

[1] https://support.apollo13.eu/discussion/6019/howto-make-google-fonts-local?
[2] https://kuehne-lange-grumfeld.de

Comments

  • AirAir
    Posts: 10,602
    Hey :-)

    You want to remove google font from your website, and use only local "device" fonts?

    Currently, it seems that you didn't change fonts in the customizer yet. I can see font is loaded for the main menu.
    Please check https://rifetheme.com/help/docs/customizing-the-theme/general-settings/fonts-settings/

    You will have to also change font settings in the Elementor to not use Google fonts.



    With kind regards.
  • Posts: 87
    Morning Air,

    thanks for your fast reply already at morning.

    I've read the help document one more time.

    Just to clarify, what I want is not using the system font. I want the respective Google font (= Quicksand) to be loaded locally from my own webspace in order to be GDPR compliant, thus not from a remote Google server.

    It's basically the same I did one year ago on my PhotoProof website. I've created a checklist based on your advise, so that I can replicate steps (which worked):

    1. Add code to functions.php (child theme)

    add_action('after_setup_theme', function(){
    
 remove_action( 'wp_enqueue_scripts', 'apollo13framework_get_web_fonts_static' );
},12);

    2. Customize > Miscellaneous > Optimization > Use the web-font loading script → Disable

    3. Add respective code to "Custom CSS" referencing to fonts on local webspace and hereby don't use relative URLs.

    Thought that's it.

    I've noticed this morning that on "Home" font Quicksand loads proper, while on all other pages a system fonts seems to be loaded. There was a copy/paste bug in URLs in Custom CSS. It routed accidentally to PhotoProof directory (where Quicksand wasn't located) instead to Rife-Pro directory. Fixed that. Now fonts load proper. Yesterday it was 1:30 a.m. at night *sic*.

    Nevertheless there still seems to be somehow a connection, even though I thought with step 2 of my checklist I pull the plug to Google. Based on https://webbkoll.dataskydd.net chapter "Third Party", Google API is still contacted to load fonts. On my other website, where I've done the exact same steps, it's not. One other thing: There is also a cookie set I don't want to be set. On PhotoProof I doesn't set this cookie.

    Best regards
    Marius (with a coffee beside him)
    Bildschirmfoto 2021-01-11 um 11.11.41.png
    2064 x 1204 - 257K
    Bildschirmfoto 2021-01-11 um 12.16.27.png
    1538 x 876 - 144K
    Bildschirmfoto 2021-01-11 um 12.17.07.png
    2286 x 1008 - 294K
  • AirAir
    Posts: 10,602
    Hey :-)

    On the home page, I can see the font is still loaded. I suspect that Elementor loads it.

    On this page, it is not loaded https://kuehne-lange-grumfeld.de/fachgebiete/ and you are not using Elementor there.

    Please try using default fonts as user did here https://wordpress.org/support/topic/elementor-loads-a-lot-of-unused-google-fonts/

    Also check this answer https://github.com/elementor/elementor/issues/4075

    Hope that helps.

    With kind regards.
  • edited January 12 Posts: 87
    Thanks to your help finally solved now!

    Thanks very much!!!!

    Frankly, this was driving me nuts in past days.

    Indeed there was one paragraph still featuring the font manually defined. For other users my recommendation would be to temporary define native system fonts via Customizer, in order to be able to figure out where Elementor setting is still set. Else you get crazy, as Elementor with it's GUI is so nested. It's not that you can get fast a 'big picture'. Else you need to do several clicks to inspect and you need to for each responsive view as well. It's also difficult to see, as being able to select or deselect in admin-panel as well, adds another location of where unwanted clicks might create trouble. E.g. in my case both options had been marked. However web fonts had still been loaded, even thought they had been disabled via Customizer.

    To wrap it up: There are too many options in Elementor for setting fonts.

    One recommendation: I don't understand why there are still almost no clickable features in most WordPress themes in order to make websites GDPR compliant. I'm talking about the main fuse you plug to kill all the "we call california" connections. There are basically two options to go for Europeans, especially Germans: Either with fonts being loaded remotely or locally. First is highly risky and so second is the king's way. It would be great if that would be fully end-2-end clickable, instead of having to patch functions.php.

    Post edited by MLG76 on
  • AirAir
    Posts: 10,602
    Hey :-)

    It is a great idea with this GDPR switch. However in our theme we call only google fonts. Rest comes from external plugins/WordPress.

    Sorry to hear that this took so much effort and time from you. waht is more you have really simple website, and still it was not easy.

    Anyway congratulations on solving this, if I can say it like this ;-)

    Great job!

    With kind regards.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion