Before you ask please READ THIS

No Images in RSS Feed

edited January 2013 in Hypershot Posts: 26
Hi,

did anything change in version 1.1 the way the rss feed is generated?
There are no more images in the last posts from my blog when I view them in the google reader.

Here is a link to the rss feed
http://www.jenslumm.com/feed/

I did check the Reading settings:
Settings > Reading > "For each article in a feed, show For each article in a feed, show" > Full text

Images are "size-medium" in posts.

Thanks a lot

Comments

  • AirAir
    Posts: 9,868
    Hello,

    Damn that is not nice, but lets do whole story.

    In change log I added Added: RSS Thumbnails(thanks rim_light)
    And now begins funny story when you will read this topic http://support.apollo13.eu/discussion/699/wrong-picture-in-rss-feed cause there user was mentioning same thing about google reader... and now we are using his code

    Anyway, to remove my change go to advance/utilities.php line last and delete this two

    add_filter( 'the_excerpt_rss', 'a13_rss_post_thumbnail');
    add_filter( 'the_content_feed', 'a13_rss_post_thumbnail');
    ----- Few minutes later ----
    OK I gave a closer look at you site, and I see you don't use featured images, and above post was about featured. If you want to keep our fix and have content images as it was in previous version, then instead of above changes do this (in same file line~897)

    change

    '</p>' . get_the_excerpt();
    }
    else
    $content = get_the_excerpt();
    to this

    '</p>' . get_the_content();
    }
    else
    $content = get_the_content();
    Sorry for problems.

    With regards.
  • You just made somebody very happy. Worked perfectly. Your support is absolutely fabulous.

    Thanks a lot!
  • AirAir
    Posts: 9,868
    Thanks for kind words:-)

    With regards.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!