Before you ask please READ THIS

Logo size issue by loading pages

in Fame Posts: 62
Hi Air,

I'm having a trouble with the logo, when I navigate on any pages of my website the logo start to appear 1-2 seconds in small and then in the size I'v defined in the css as indicated in Fame's doc (.highresdisplay), same by refreshing the page. So that the navigating is kind of "jumpy". Any idea how I could correct this issue?

Here the website:
http://www.kissthedesign.ch/

Thanks in advance for your help :-)

Comments

  • AirAir
    Posts: 10,851
    Hello :-)

    I tested it on FireFox and didn't experience anything like that. On what device/browser you see it?

    With kind regards.
  • Hi, many thanks for your reply. I'v tested on both firefox and safari and the issue appears on both browser. I have a new Retina screen, maybe this is buggy on high res screen?
  • AirAir
    Posts: 10,851
    I think it is caused by your CSS in child theme
    .highresdisplay #logo img {
    width: 300px !important;
    height: auto !important;
    }
    And that, that you have same size logo in hight dpi option, while you should have twice as big.

    Experiment some with both those things.

    With kind regards.
  • Hi Air, I'v changed the size of the high res logo and put it twice as big as you said, unfortunately no change.. So it should be the CSS, but what's the problem of it? this is the code I'v find on your documentation.. what should I change in the css? Is there another way to have the logo to display in a big size?
    Thanks :-)
  • AirAir
    Posts: 10,851
    I have checked few times - you still have same logo there for HIGH dpi screens.
    As for CSS - remove it for now.

    With kind regards.
  • Hi Air, well there is an issue with this function, since when I select the high res logo and save, it actually doesn't change my changes..?? I'v tried to change the logo image too, but impossible to save any logo change :-/ Any clue?
    I'v removed the CSS now.
  • Hi Air, this is really strange the logo now looks big in the english and german website, but small in the main website in french...Any way to make the logo looks consistent through the whole website (in any language)? Actually the size of the logo in the english and german version looks the way I'd like to.
    Many thanks for your help :-)
  • AirAir
    edited September 2016 Posts: 10,851
    That might be the reason why you don't see any changes - WPML. Logo is translatable between languages, what means that you have to change it in WPML settings per each language. I think I will remove it in next version, so it wouldn't cause problems.

    Anyway for now do such things:
    1. Disable WPML.
    2. Go to fame\wpml-config.xml line ~28 and remove following lines:
    
                <key name="logo_image" />
                <key name="logo_image_high_dpi" />
                <key name="logo_image_high_dpi_sizes" />
                <key name="logo_text" />
    
    3. Re enable WPML.
    4. Now you should be able to make all logo changes by theme settings.

    With kind regards.
    Post edited by Air on
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!